Installing on Other UNIX platforms

The following installation files are available with the product to support platforms that require a version of a Java Runtime Environment (JRE) other than the one provided by the installer. No JRE is installed with these files.

Platforms that may use these files include z/OS, Mac, HP-UX, Solaris, and other Linux systems.

Automated installer

For example:

mss-12.2.<build number>-prod-unix-nojre.sh

Manual installer

For example:

mss-prod-unix-nojre-manual.tar.gz

Manual Installer for Security Proxy only

securityproxy-prod-unix-nojre-manual.tar.gz

Procedure for Installing with no JRE

  1. To use any of these -nojre- installation packages, confirm that a Java runtime environment appropriate for your platform is already installed. For example, to install Management and Security Server on a z/Linux machine, download the JRE from this location:

    http://www.ibm.com/developerworks/java/jdk/linux/download.html

  2. Expand the package you want to use (Automated Installer, Manual Installer, Manual Installer for Security Proxy Only). The guidelines described for full multi-component install options also apply here; however, these packages do not include a JRE so that the Java version installed on your platform can be used during installation.

    Note: Your JRE must be Java version 7 or higher.

  3. Be sure that the JCE Unlimited Strength Jurisdiction Policy Files are applied, and apply them each time you upgrade your JRE. See Applying the JCE Unlimited Strength Jurisdiction Policy Files.