System Requirements

Requirements for Reflection Desktop can vary, depending on your hardware and other software components present. For complete information about deploying Reflection in virtualized environments and other supported platforms, see Technical Note 2809.

Processor

2 GHz, 32-bit or 64-bit (1.5 GHz or higher multi-core, 32-bit or 64-bit recommended)

System memory (RAM)

2 GB (4 GB recommended)

Operating system and platform

One of the following:

 

Microsoft Windows 10 Pro 32-bit and 64-bit

 

Microsoft Windows 10 Enterprise 32-bit and 64-bit

 

Microsoft Windows 8.1 Pro 32-bit and 64-bit

 

Microsoft Windows 7 Enterprise 32-bit and 64-bit

 

Microsoft Windows 7 Ultimate 32-bit and 64-bit

 

Microsoft Windows Server 2016 with Remote Desktop Services (for multi-user environments)

 

Microsoft Windows Server 2012 R1 or R2 with Remote Desktop Services (for multi-user environments)

 

Microsoft Windows Server 2008 R1 or R2 with Windows Terminal Server (for multi-user environments) 32-bit and 64-bit for R1 (64-bit only for R2)

Additional software requirements

To use the Office integration features in Reflection, Microsoft Office 2007 or later must be installed.

Prerequisite software — Microsoft .NET Framework

Reflection Desktop requires .NET Framework 4.5.1 or later. If the required .NET Framework isn't installed, the Reflection Setup program installs version 4.5.1 on all systems except Microsoft Windows Server 2008 R1 and later.

Notes:

  • If you install Reflection directly with MSI and the product features you install do not require .NET 4.5.1, you can add the SKIPDOTNET=1 property to the command line to bypass this test condition.

Microsoft Windows Installer 4.5

The Microsoft Windows Installer (MSI) version 4.5 is distributed with Reflection Desktop.

Microsoft Visual Basic for Applications (VBA)

Reflection Desktop supports Microsoft VBA 7.0. If you select to install this feature in the Reflection Setup program, it is automatically installed. If you install Reflection Desktop directly with MSI or with a deployment tool and you want to install this feature, you must install it directly, using the core VBA 7.0 MSI and an appropriate language specific MSI (these MSIs are in the Prerequisites folder, in the distribution media).